当前位置:首页 > 问答

通达信wma

我来帮TA回答

请哪位老师把下面公式改成通达信公式,谢谢!

KN:=IF(PERIOD=35,144,IF(PERIOD>=5 AND PERIOD<=8,21,IF(PERIOD=4,34,IF(PERIOD=3,55,IF(PERIOD=2,55,89)))));
DK:=XHX(52,H,L,O,KN);
XHX 在通达信利是没有这个函数的,不知其意义是无法替代的。另外,这个是哪种软件上用的公式?

求通达信加权平均线公式(想设8条均线),谢谢老师

兄弟,您想要加权平均线么,要先说说权重是多少,比如要换手率当权重等!

请将大智慧主图公式改为通达信版本,并将坚决买入做成通达信选股公式

A1:= WMA(CLOSE,22);
A2: WMA(CLOSE,55),LINETHICK0,COLOR00FFFF;
A3:= WMA(CLOSE,34);
生命线: WMA(CLOSE,14),LINETHICK2,COLOR80FF00;
年线: WMA(CLOSE,250),LINETHICK0,POINTDOT,COLORFFFFFF;
B:= 生命线>A1 AND A1>A2 AND A2>A3;
B1:= COUNT(B,2)=1 AND REF(A2,1)<=REF(A3,1);
VV2:= REF(CLOSE,1);
VV3:= SMA(CLOSE-VV2,6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWTEXT(REF(VV3,1)>81 AND VV3<80,HIGH,'闪人↓'),COLOR00FFFF;
红包:= IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,10,-5);
动态底部:= EMA(IF(LOW<=LLV(LOW,30),SMA(ABS(LOW-REF(LOW,1)),30,1)/SMA(MAX(LOW-REF(LOW,1),0),30,1),0),3)*10;
PP:= 红包=10 AND 动态底部>10;
DRAWTEXT(PP,HIGH,'坚决买入'),COLOR00FF00;
这样就可以在主图用了。下面是选股用:
红包:= IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,10,-5);
动态底部:= EMA(IF(LOW<=LLV(LOW,30),SMA(ABS(LOW-REF(LOW,1)),30,1)/SMA(MAX(LOW-REF(LOW,1),0),30,1),0),3)*10;
PP:红包=10 AND 动态底部>10;

如何在通达信设置wma趋势参数?

新建一个主图叠加公式就可以用wma42日指标来.

代码如下

wma(c,42);

计算含义如图

如果实在看不懂这个wma加权计算含义很简单.

例如计算一个2日的wma指标

(第一日*1+第二日*2)/(1+2)

如果是计算3日

(第一日*1+第二日*2+第三日*3)/(1+2+3)

以此类推就可以了

这样计算也就是越新的日期所占的权重比例越大,所以叫加权平均.

手机版通达信如何添加看盘指标

所有手机行情软件都不支持指标导如入,只能用他系统自带的指标,希望帮到你

通达信手机版可以导入指标公式吗

目前还没有发现手机版的软件可以自编公式的(包括导入)。